Skip to main content
← All vulnerabilities
CVE-2025-6709

Pre-Authentication Denial of Service Vulnerability in MongoDB Server's OIDC Authentication

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 7.0.17, 8.0.5, 6.0.21
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: yes
  • Technical impact: partial

Summary

The MongoDB Server is susceptible to a denial of service vulnerability due to improper handling of specific date values in JSON input when using OIDC authentication. This can be reproduced using the mongo shell to send a malicious JSON payload leading to an invariant failure and server crash. This issue affects MongoDB Server v7.0 versions prior to 7.0.17 and MongoDB Server v8.0 versions prior to 8.0.5. The same issue affects MongoDB Server v6.0 versions prior to 6.0.21, but an attacker can only induce denial of service after authenticating.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: yes · Technical impact: partial

  3. Record last updated

Affected versions

  • MongoDB Inc MongoDB Server

    From 7.0 · fixed in 7.0.17; From 8.0 · fixed in 8.0.5; From 6.0 · fixed in 6.0.21

References 1

jira.mongodb.org