Skip to main content
← All vulnerabilities
CVE-2025-66169GHSA-4JRW-64VR-7G8M

Apache Camel Neo4j: Cypher injection vulnerability in Camel-Neo4j component

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 4.10.8, 4.14.3, 4.17.0
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: partial

Summary

Cypher Injection vulnerability in Apache Camel camel-neo4j component. This issue affects Apache Camel: from 4.10.0 before 4.10.8, from 4.14.0 before 4.14.3, from 4.15.0 before 4.17.0 Users are recommended to upgrade to version 4.10.8 for 4.10.x LTS and 4.14.3 for 4.14.x LTS and 4.17.0.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: partial

  3. Record last updated

Affected versions

  • org.apache.camel:camel-neo4j

    From 4.10.0 · fixed in 4.10.8; From 4.14.0 · fixed in 4.14.3; From 4.15.0 · fixed in 4.17.0

  • org.apache.camel:camel-neo4jMaven

    From 4.10.0 · fixed in 4.10.8

  • org.apache.camel:camel-neo4jMaven

    From 4.14.0 · fixed in 4.14.3

  • org.apache.camel:camel-neo4jMaven

    From 4.15.0 · fixed in 4.17.0

References 1

camel.apache.org