CVE-2025-65960GHSA-98VJ-MM79-V77R
Contao is vulnerable to remote code execution in template closures
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 4.13.57, 5.3.42, 5.6.5
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
CISA's decision points: whether it is exploited, whether attacks can be automated, and how much control an attacker gets. Assessed (SSVC 2.0.3).What do these mean? →
- Exploitation: none
- Automatable: no
- Technical impact: total
Summary
Contao is an Open Source CMS. From version 4.0.0 to before 4.13.57, before 5.3.42, and before 5.6.5, back end users with precise control over the contents of template closures can execute arbitrary PHP functions that do not have required parameters. This issue has been patched in versions 4.13.57, 5.3.42, and 5.6.5. A workaround for this issue involves manually patching the Contao\Template::once() method.
Timeline
- CVE published
- CISA SSVC assessment
Exploitation: none · Automatable: no · Technical impact: total
- Record last updated
Affected versions
- contao contao
From 4.0.0 · fixed in 4.13.57; From 5.0.0-RC1 · fixed in 5.3.42; From 5.4.0-RC1 · fixed in 5.6.5
- contao/core-bundlePackagist
From 4.0.0 · fixed in 4.13.57
- contao/core-bundlePackagist
From 5.0.0-RC1 · fixed in 5.3.42
- contao/core-bundlePackagist
From 5.4.0-RC1 · fixed in 5.6.5