CVE-2025-6544PYSEC-2026-349GHSA-5W3J-GWGH-4RFV
Deserialization Vulnerability in h2oai/h2o-3
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 3.46.8
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
A deserialization vulnerability exists in h2oai/h2o-3 versions <= 3.46.0.8, allowing attackers to read arbitrary system files and execute arbitrary code. The vulnerability arises from improper handling of JDBC connection parameters, which can be exploited by bypassing regular expression checks and using double URL encoding. This issue impacts all users of the affected versions.
Timeline
- CVE published
- Record last updated
Affected versions
- h2oai h2oai/h2o-3
From unspecified · fixed in 3.46.8
- ai.h2o:h2o-coreMaven
through 3.46.0.7
- h2oPyPI
through 3.46.0.7