Skip to main content
← All vulnerabilities
CVE-2025-64408GHSA-WQ4C-57MH-5F7G

Apache Causeway: Java deserialization vulnerability to authenticated attackers

Published
Last modified
published
Not listed in CISA KEV
Critical (apache)
Fix
Fixed in 3.5.0
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: total

Summary

Apache Causeway faces Java deserialization vulnerabilities that allow remote code execution (RCE) through user-controllable URL parameters. These vulnerabilities affect all applications using Causeway's ViewModel functionality and can be exploited by authenticated attackers to execute arbitrary code with application privileges.  This issue affects all current versions. Users are recommended to upgrade to version 3.5.0, which fixes the issue.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: total

  3. Record last updated
  4. EPSS reached 10%

    FIRST estimates at least a 10% chance of exploitation in the next 30 days

Affected versions

  • org.apache.causeway:*

    From 2.0.0 · through 3.4.0

  • org.apache.causeway.commons:causeway-commonsMaven

    fixed in 3.5.0

  • org.apache.causeway.core:causeway-applibMaven

    fixed in 3.5.0

  • org.apache.causeway.core:causeway-coreMaven

    fixed in 3.5.0

  • org.apache.causeway.viewer:causeway-viewer-wicketMaven

    fixed in 3.5.0

References 1

lists.apache.org